1. Приглашаем вступить в нашу группу ВКонтакте.
    Скрыть объявление
  2. Присоединяйтесь к нашему чату по ссылке: http://t.me/mediawiki_ru
    Скрыть объявление

Отображение отдельных изображений

Тема в разделе "Основные вопросы по Media Wiki", создана пользователем masteranonimus, 29 авг 2017.

  1. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Возникла проблема с изображениями. Конкретно при клике на любое загруженное изображение попадаю на 404. Как избавится от этого?
     
  2. aka_sektor
    Оффлайн

    aka_sektor Осваивается

    Регистрация:
    21 дек 2015
    Сообщения:
    278
    Симпатии:
    14
    Пол:
    Мужской
    Просто так файлы не пропадают. Что делали до того как заметили что не работает?
     
  3. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
    Ссылка на посмотреть тоже была бы не лишней.
     
  4. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Дело в том, что я установил чистую версию mediawiki, всё тоже самое. Может быть, я не активировал функцию какую...
    Ссылка
     
    Последнее редактирование: 30 авг 2017
  5. Wikijournal
    Оффлайн

    Wikijournal Прижился

    Регистрация:
    24 сен 2013
    Сообщения:
    586
    Симпатии:
    34
    Пол:
    Мужской
    Меня смущают настройка короткой ссылки - может дело именно в этом!?
     
  6. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
  7. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Дело в том, что, я установил абсолютно чистую версию mediawiki на тестовый домен и там тоже самое.
     
  8. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Сделал всё как говорится на странице. Добавил .htaccess и в локал, не помогло :(
    Восстановил LocalSettings даже без ЧПУ не работает.
     
    Последнее редактирование: 30 авг 2017
  9. Wikijournal
    Оффлайн

    Wikijournal Прижился

    Регистрация:
    24 сен 2013
    Сообщения:
    586
    Симпатии:
    34
    Пол:
    Мужской
    Выложи localsettings.php
     
  10. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
     

    Вложения:

  11. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
  12. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
  13. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Помогло, просто включил Apache вместо Nginx для обработки статических файлов и всё заработало.

    Кстати, обязательно ли мне всё проделывать для чпу в .htaccess?
    Чем черевато если я просто пропишу в конфиг?
    Код:
    $wgArticlePath = "/wiki/$1";
    Просто разницы не замечаю. Всё работает
     
  14. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
    А он и не рработает потому что, эти настройки работают только для апача.
     
  15. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    В плане не работает? Ссылки же сокращены. вида ".com/Статья"
     
  16. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
    То что описано в htaccess не работает, работает то что в конфиге nginx.
     
  17. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    Т.е. строчки в конфиге достаточно чтобы всё адекватно работало?
     
  18. UksusoFF
    Оффлайн

    UksusoFF Moderator Команда форума

    Регистрация:
    13 май 2013
    Сообщения:
    1.687
    Симпатии:
    199
    Пол:
    Мужской
    Адрес:
    Самара
    В localsettings и конфиге nginx. В этом случае то что должно быть в htaccess прописывается гдето в /etc/nginx/sites-enabled Но с учетом правил nginx. Если брал какой-то готовый конфиг, то скорее всего там это уже есть.
     
  19. masteranonimus
    Оффлайн

    masteranonimus Только зашёл

    Регистрация:
    29 авг 2017
    Сообщения:
    9
    Симпатии:
    0
    К etc хостер не предоставляет доступ. Видимо там уже есть всё. :D Ладно, спасибо большое за помощь! Темку можно закрыть :)
     

Поделиться этой страницей