Ошибка Lua в Модуль:Wikidata на строке 123: attempt to index field 'wikibase' (a nil value).

Тема в разделе 'Для новичков', создана пользователем Дмитрий911, 1 июн 2015.

  1. Дмитрий911
    Оффлайн

    Дмитрий911 Только зашёл

    Дата регистрации:
    1 июн 2015
    Сообщения:
    2
    Симпатии:
    3
    Пол:
    Мужской
    Добрый день.

    У меня проблема с настройкой wikimedia.
    Я загрузил все нужные дампы на сервер MySQL, установил Wikimedia, подключил модули wikibase и wikidata, но когда захожу на какую либо страницу вылазит ошибка Ошибка Lua в Модуль:Wikidata на строке 123: attempt to index field 'wikibase' (a nil value). Причем, не на всех строках. Какие то грузятся нормально, а на других вылетает эта ошибка.
    Так же фигурирует другая ошибка Ошибка Lua: callParserFunction: function "#property" was not found.
    Бьюсь уже неделю, не могу понять причину. Во вложении файл localsettings.php(отрывайте токо в Notepad++, а то форматирование убивается). Так же предоставляю скриншот проблемы.

    Так же я пробовал подключаться как репозиторий, но проблема так же.

    Помогите, добрые люди)

    Вложения:

    • LocalSettings.txt
      Размер файла:
      6 КБ
      Просмотров:
      7
    • 1.jpg
      1.jpg
      Размер файла:
      244,9 КБ
      Просмотров:
      10
    vladimirpoland и indigo888 нравится это.
  2. Дмитрий911
    Оффлайн

    Дмитрий911 Только зашёл

    Дата регистрации:
    1 июн 2015
    Сообщения:
    2
    Симпатии:
    3
    Пол:
    Мужской
    Проблему решил.
    Не был подгружен дамп wb_items_per_site
    indigo888 нравится это.
  3. indigo888
    Оффлайн

    indigo888 Только зашёл

    Дата регистрации:
    9 май 2016
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Добрый день. Имеется аналогичная проблема а также другие проблемы с настройками. Несколько месяцев пытаюсь настроить, но ничего не получается. Был бы Вам очень признателен если бы Вы скинули мне архив с вашим настроенным и работающим проектом mediawiki (почта xspacebox@gmail.com) (предварительно удалив ваши пароли из LocalSettings.php).
    Последнее редактирование: 9 май 2016
  4. vladimirpoland
    Оффлайн

    vladimirpoland Только зашёл

    Дата регистрации:
    13 апр 2017
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Привет коллеги!

    Установил все по инструкции (Mediawiki, дампы в MySQL, модули Scribunto, Wikidata, Wikibase), раньше вылетало "...attempt to index field 'wikibase' (a nil value)", а теперь вместо имеем на экране Lua error: Internal error: The interpreter exited with status 1.

    Дамп wb_items_per_site также загружен.

    Включил файл лога $wgScribuntoEngineConf['luastandalone']['errorFile'], и получил "расширенный" ответ - "Системе не удается найти указанный путь."

    Что может быть не так?